Installing on Server 2008

Topics: Developer Forum
Nov 3, 2010 at 3:13 PM

Hi I get this error when trying to access my webpage using the activfp on server 2008.

 Caught .NET exception, source: servervariables err#= 1925 line= 1444 Unknown member OREQUEST.1925 Unknown member OREQUEST. OREQUEST .NULL. .NULL. .NULL. .NULL. d:\inetpub\vhosts\\httpdocs\osonline\activevfp.dll message: d:\inetpub\vhosts\\httpdocs\osonline\activevfp.dll

I have however manaed to get this to work on a windows xp machine.


Can anyone please help




Nov 3, 2010 at 10:33 PM

Sounds like you don't have ASP installed on the Server 2008.  You need both ASP and ASP.NET installed.

Nov 4, 2010 at 1:11 PM

Hi cludefox

Thanks for your reply. I have double cheked and the server has the latest versions of both ASP and AP.NET installed.

I tried regsvr32 on the activevfp.dll which registered ok and also tried setting up the COM part which runs ok but I still get exactly the same error.

I really am stuck on this one.

Any other suggestions or ideas would be very much appreciated.

Best Regards



Nov 4, 2010 at 2:24 PM

try running a simple asp script  (anything.asp) and let me know if it works.  The oRequest is just a wrapper around the ASP Request intrinsic object - no reason for it not to be there if ASP is properly set up..

Nov 4, 2010 at 5:54 PM

Hi claudefox

I tried running a simple calendar.asp which pops up a basic calendar and had no errors at all.

As soon as i tried the default.asp or default.aspx  I got the error.

I uninstalled everything and tried again but still no luck.

I am using IIS 7 if that makes any difference.

Appreciate your help




Nov 4, 2010 at 6:31 PM
Edited Nov 5, 2010 at 1:20 AM

Hmm that's kinda weird.  IIS 7 should work great.  That's what is being used at GoDaddy:

So you're using ActiveVFP 5.0 with ASP.NET 2.0 ??    At GoDaddy I've got Pipeline mode set to 'Classic' and I'm using ASP.NET 1.1 (altho I don't know why that would make a difference on your server).  Also is it 64 bit Windows and, if so, did you enable 32-bit for IIS?

Please let us know if one of these fixes your problem.

Nov 5, 2010 at 11:15 AM

Hi claudefox

Thanks for your replies.

I am using activevfp5 with asp net 2. v 2.050727 - I set the pipeline mode to classic and still no luck . I installed ASP.NET 1.1 and pointed the app pool to that and still no luck.

It is not a 64 bit machine but 32.

I have tried under activevfp4.1 and still the same problem - as i said before i can get this to work without any hassle on a windows xp an iis 6.

really stuck now.  any more suggestions will be very welcome.



Nov 5, 2010 at 1:05 PM

What's the URL you're using??  Something like "" should not even be calling oRequest.servervariables.  I see servervariables method being called for Authentication, Graphs, and PDFs. in main.prg, none of which you're doing in the basic URL...

Nov 8, 2010 at 9:04 AM

Hi claudefox

I decided to install the full version of vfp9 onto the server and the problem magically disappeared.

Im not sure what was missing as i installed the vfp runtime licence beforehand.

Anyway thanks very much for your help.



Nov 8, 2010 at 9:50 AM

Glad you got it to work.  AVFP 5 doesn't need the runtime added since it's included and runs from the same directory as activevfp.dll so there shouldn't be any conflicts.  So I'm not sure what happened but if you had multiple versions of avfp and the vfp runtime on that machine, that may account for some of the strange behaviour...   

Nov 12, 2010 at 1:50 PM

Hi claude fox

Sorry to bother you again but I have a similar problem to above again.

 have one web site working fine but after trying to setup a second web site on the same 2008 machine  i am getting the following error when i try and access the site. I have made sure i only have one version of the activevfp.dll installed and have regsvr32 it in the windows32 directory.

The error is as follows:

init err#= 1925 line= 40 Unknown member OCONTEXT.1925 Unknown member OCONTEXT. OCONTEXT .NULL. .NULL. .NULL. .NULL.

c:\windows\system32\activevfp.dll error '80004005'

Everything is setup in the same way as the first web site but this one just wont work at all.

Any ideas will be very much appreciated yet again.



Marc Wright

Nov 12, 2010 at 2:42 PM

So you have several sites on that same 2008 Server?  Is this with any URL?  What is the URL?

For some reason, it's having a problem finding the ASP intrinsic objects on your machine.  This is the first case of that I've heard of if everything is properly setup.  At this point it's still a mystery for me why this is happening.

If you haven't already, make sure ASP is enabled for any new virtual directory or application in IIS.

Nov 17, 2010 at 8:10 AM

Hi Claudefox

To resolve this problem I basically had to start from scratch. I unregistered the activevfp.dll and removed any mention of it from the regisrty and rebooted the machine. I then  copied everything from scratch and everything worked first time.

I guess I must have had different activevfp.dlls hanging around or something like that,

Thanks for you help.