GoDaddy 10 step and done!

Coordinator
Feb 18, 2011 at 9:56 AM
Edited Nov 20, 2014 at 6:27 PM
1.) Download "ActiveVFP 6.03 Zip File (IIS7 and above)" from the downloads page.

2.) Get GoDaddy account from here.

3.) Go to GoDaddy.com and Log In.

4.) From the Products menu, choose "Hosting and Servers" And then "Manage Now".

5.) Go to the "Web Hosting" section, choose your Domain, and press the "Launch" button".

6.) Under "Hosting Details" and "Tools", choose "IIS Management".

7.) Make sure it says "ASP.Net Runtime Version: 4.0/4.5". If not, choose "Modify" to change it. Make sure "Pipeline" at the top is set to "Integrated".

8.) Choose "Create". Enter a "Directory" name and check all of these: "Anonymous Access", "Directory Browsing",
"Set Application Root". Press OK. This will process for a little while.

9.) Press the browser Back button and under "Hosting Details" and "Tools", choose "File Manager".

10.) At the top of the page, choose "Upload File". Press the "Browse" button and browse to the ActiveVFP6.03.Zip file you downloaded in Step 1. Press the "Upload" button.

11.) Check on the left side of File Manager to see if the Directory you created in Step 8 exists yet. Refresh the page until you see it.

12.) In File Manager, place a check by the file ActiveVFP6.03.zip you uploaded in Step 10. Choose "Unarchive" at the top. Under "Select Destination", choose the Directory name you created in Step 8.

13.) Navigate to your new directory by clicking it in the left pane of File Manager. In your new directory's list of files , find the "Web.config" file (page 3 of files) and check it. Choose "Edit" from the list at the top. Make sure the following entry is there:
<system.web>
    <trust level="Full" />
    <httpModules>
Save the file.

14.) Go back to page 1 of the files in your new directory. Find the "Data" folder and place a check by it. Choose "Permissions" at the top. Check "Read" and "Write". Press OK. Repeat these steps for the "Temp" directory.

15.) Test by typing the following into your browser: http://www.yourdomain.com/yourdirectory/default.avfp
Oct 7, 2013 at 7:13 AM
Worked flawlessly on GoDaddy following instructions exactly as laid out.
Coordinator
Oct 7, 2013 at 2:08 PM
Claude, I think it was noted as well in the foxite forum. The list contains 15 items not 10. :)
Dec 10, 2014 at 7:19 AM
Hi,
I realise this is an old thread, but I'm hoping someone can help:
I tried this with an existing basic webhosting account with GoDaddy - I switched it from linux to ms for the purpose.
First I could only choose between asp.net v 1 and 2 (not 4) - I chose 2 because that's what is set up on my local IIS (on Win7 Home Prem) (I was then unable to switch back to 1 to try that).
I uploaded avfp6 (as covered here) and avfp5 (as mentioned in the docs for use with GoDaddy).
When setting file permissions there is no 'permissions' menu - only 'privacy' which was defaulted to Inherit (web read only); I unchecked inherit and checked web read, Web write, Allow sub-folders to Inherit.

If I put in the <trust level="Full" /> that line throws an error:
This configuration section cannot be used at this path. This happens when the site administrator has locked access to this section using <location allowOverride="false"> from an inherited configuration file.

If I don't put it in the error is:
System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

So basically it doesn't work (avfp6 works fine locally)

thanks AndyD
Dec 10, 2014 at 9:04 AM
Andy. I didn't try avfp5 on GoDaddy; just 6 and it worked fine for me.
Dec 17, 2014 at 2:00 AM
Hello everyone,

It's been 4 weeks roughly since I've been gathering resources to once again start developing in Foxpro. I came across activeVFP and it's what I'm been searching for. It would be wonderful to get it working from the {url: http://www.activitymail.com/fp/} and not having to type 'default.avfp'. I've read everything and nothing seems to work. I followed everything carefully installing it on 3 web hosting site including GoDaddy + on my computer in Windows 7.

It works for (http://victorespina.com.ve/avfpsb/) and (http://www.boblindsayhonda.com/). My search led me to Victor Espina's find at (http://www.foxite.com/archives/activevfp-getting-started-0000409165.htm). He said:

...Current release of AVFP has a bug on MAIN.PRG that avoids to automatically open Default.avfp if you point to the root folder, i.e., http://localhost/demo/. This can be fixed adding the line:
oProp.Ext = ".avfp"
The website popped right up but all links resolve to root.

Can anyone help? Thank you in advance.
Dec 17, 2014 at 9:31 AM
http://www.activitymail.com/fp/ opened up (on the test page) OK for me - I did not have to type 'default.avfp'.
BUT none of the links that I tried worked (the other sample sites you linked did work) - folder permissions?

P.S. You say you set up OK on GoDaddy - see my post above - could you please post brief details of your GoDaddy setup:
avfp version; asp.net version; permissions/privacy settings, trust level setting etc.

many thanks
Coordinator
Dec 17, 2014 at 8:45 PM
Those error messages indicate it can't find your data.
The AVFPInit function in main.prg and looks like this (and works out of the box upon installation):
SET PATH TO oProp.AppStartPath+'data\AVFPdemo41\' && SET DEFA TO 'c:\mydata\'
oProp.DataPath = oProp.AppStartPath+'data\AVFPdemo41\'

change to the hardcoded version if you have to.

(You have to set read\write permissions on that data folder but that's a different error message if it's not set up).
**
There's a way to not have to specify default.avfp using the web.config file. I'm searching for this documentation now and will fill in here when I find it.

And, of course, there is never a need for any extension if you use VFP Controllers.
**
Regarding GoDaddy, if you signed up for the current Economy service (I believe it's like $1 a month now), then you should be good to go with the instructions above.

My GoDaddy setup is IIS7, ASP.Net Runtime Version: 4.0/4.5 , Integrated Pipeline mode on the latest economy hosting AFAIK.
Dec 17, 2014 at 8:46 PM
GOOD NEWS!

First ActiveVFP is worth the learning curve frustrations: better now than 1 minute before launch.

Andyfd, thanks for responding and for everyone who contributes to make the various improvement to a wonderful product=activevfp.

After many hours and activevfp didn't work I re-installed it in a different folder via the 'Virtual Directories' option in Websites & Domains'. I guess the root folder is automatically 'virtual'?

I took your steps one by one (refreshing each time)='avfp version'; reset hosting defaults and apply one-by-one (refreshing each time)='avfp'. All permissions='full control', trust level=full; etc.

Finally, a better result and GOOD indication: the images and banner is showing up. Entering (http://activitymail.com/fp) appends the '/' and then produces "Caught .NET exception, source:.." on some links. Easy fix.

Works even from my phone! Woohoo!

Thanks very much!
Dec 18, 2014 at 8:21 AM
Edited Dec 18, 2014 at 8:29 AM
OK I sorted out the problem with GoDaddy - I had Economy Classic which only offers asp.net v 1 and 2 (not 4). There is a message to upgrade if you want v4.
I looked under the Godaddy 'Customise' option and could only see DeLuxe, which I don't need. However I tried again yesterday and after I scrolled down the list of options and then up again, more options appeared including a no-cost change to Economy Web hosting. I chose this, and after a couple of hours I refreshed the App pool and Hey Presto! I had the test page on my browser. The simple pages work fine; smtp mail doesn't but I didn't expect it o (Gmail requires secure login). Upload didn't work either but I'll look into he code for that (maybe html type?), and I haven't set up any SQL server yet - but rarin' to go.

Cheers

P.S. the images didn't appear at first, but that was because I'd included /html/ in the path- which confused the relative pathing

P.P.S I played with 'fox on a web page' many years ago using a mutithreaded vfp com object; but I could only get it to work on localhost because most ISPs (and employers) won't let you register a com on their servers - how does avfp get around this?
Coordinator
Dec 18, 2014 at 9:16 AM
Glad it's working out for everybody.

AVFP uses "side by side" automatic COM registration which basically means you don't need a command line to set it up and start using it. This is especially good for set up at ISPs or any host that wants to give you minimum access to their servers.
Jan 2 at 10:58 AM
Edited Jan 2 at 11:14 AM
I have slightly updated this to reflect the new Godaddy interface:

GoDaddy – 15 steps and done!



1.) Download "ActiveVFP 6.03 Zip File (IIS7 and above)" from the downloads page.

[2] Get GoDaddy account.

3.) Go to GoDaddy.com and Log In.

4.) From the Products tab, choose "Web Hosting", choose your Domain, and press the "Launch" button".

5.) Under "Options and Settings" scroll down to "Tools" and choose "IIS Management".

6.) Make sure it says "ASP.Net Runtime Version: 4.0/4.5". If not, choose "Modify" to change it. Make sure "Pipeline" at the top is set to "Integrated". If v. 4.0/4.5 is not available you may get a message saying you need to upgrade – if you have Economy Classic change to Economy Web (it is a no-cost change – you may need to scroll up and down and back up the options to see it).

7.) Choose the "Create+" icon and enter a "Directory" name (e.g. AVFP) and check all of these: "Anonymous Access", "Directory Browsing", "Set Application Root". Press OK. This will process for a little while with “Pending Setup” showing – Click the ‘Refresh List’box to monitor progress.

8.) Press the browser Back button and under "Options and Settings" scroll to "Tools", and choose "File Manager" (or it may still be available as a browser tab).

9.) At the top of the page, choose "Upload " and choose "File" button and browse to the ActiveVFP603.Zip file you downloaded in Step 1. Wait for it to Upload.

10.) Check on the left side of File Manager to see if the Directory you created in Step 7. exists yet. Refresh the page until you see it. Be very careful in File Manger – drag&drop is enabled and it is very easy to mess up the directory tree by accident.

11.) In File Manager, place a tick by the file ActiveVFP603.zip you uploaded in Step 9. Choose "Extract" from the ‘More’dropdown at the top and in the Extract popup choose the Directory name you created in Step 7.

12.) Select your new directory by clicking it in the left pane of File Manager and, find the "Web.config" file in the right-hand pane and click it. It will open in an "Edit" box. Make sure the following entry is there:
<system.web>
<trust level="Full" />
<httpModules>
Click ‘Save’ and ‘Çlose’

13.) In the right-hand pane of your new directory tick the "Data" folder and choose "Privacy" at the top. UnCheck "Inherit" and Check "Web visible" and "Web writable", optionally Check "Set all subfolders to inherit…". Press OK. UnTick the folder. Repeat these steps for the "Temp" directory.

14.) It might be useful at this point to go back to IIS Management and click “Recycle App Pool”

15.) Test by typing the following into your browser: http://www.yourdomain.com/yourdirectory/default.avfp