IIS 7 Installation

Dec 13, 2011 at 12:37 AM

I'm getting the following:

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

Line 6:      <trace enabled="true" pageOutput="false" writeToDiagnosticsTrace="true" />
Line 7:      <compilation debug="true" />
Line 8:      <authentication mode="Windows" />
Line 9:      <httpModules>
Line 10:       <add name="HttpModule_ProcessManifest" type="MazeComputer.AspManifestHelpers.HttpModule_ProcessManifest, AspManifestHelpers" />


Source File: C:\OBWeb\www\_activevfp\web.config    Line: 8

I'm having a problem with the installation instructions:

Particularly line 7:
7.) In IIS Manager create an Application (Windows 7, Vista, or above)  or Virtual Directory (Windows 2003 Server or below) over the folder by right-clicking Default Web Site and taking the appropriate option.  If asked, give Write and Script permissions.  

I point to the directory: eg.  C:\OBWeb\www\_ActiveVFP   (Where actovevfp.dll resides)

but when testing the path it is considered "Invalid Application Path"

Should I use the "Default Web Site" or the "ObWeb" which I've added as a site. 

Thanks,

Mark

 


Version Information: Microsoft .NET Framework Version:2.0.50727.5448; ASP.NET Version:2.0.50727.5420

<!-- [ConfigurationErrorsException]: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. (C:\OBWeb\www\_activevfp\web.config line 8) at System.Configuration.ConfigurationSchemaErrors.ThrowIfErrors(Boolean ignoreLocal) at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject) at System.Configuration.BaseConfigurationRecord.GetSection(String configKey, Boolean getLkg, Boolean checkPermission) at System.Configuration.BaseConfigurationRecord.GetSection(String configKey) at System.Web.Configuration.RuntimeConfig.GetSectionObject(String sectionName) at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index) at System.Web.Configuration.RuntimeConfig.get_CustomErrors() at System.Web.Configuration.CustomErrorsSection.GetSettings(HttpContext context, Boolean canThrow) at System.Web.HttpResponse.ReportRuntimeError(Exception e, Boolean canThrow, Boolean localExecute) at System.Web.HttpContext.ReportRuntimeErrorIfExists(RequestNotificationStatus& status) -->

Coordinator
Dec 13, 2011 at 4:17 AM
Edited Dec 13, 2011 at 4:18 AM

Usually when you get "This error can be caused by a virtual directory not being configured as an application in IIS.", it means you configured as a Virtual Directory in Win7 or Vista and it just needs to be converted to an Application (right click in IIS Manager and 'Convert to Application')


C:\OBWeb\www\_ActiveVFP  should work but I would suspect the underscore ("_") if anything.  No don't use "Default Web Site" unless you actually named the physical directory that (which you probably shouldn't)..

IOW, I would rename that Physical Directory to not have the underscore and modify the Web Application in IIS  manager to read it
 
or create a new Web Application in IIS Manager...


Dec 13, 2011 at 12:11 PM
Dear Claude,
Thanks for your prompt response.
IIS-7 allows me to add “C:\OBWeb\www\_ActiveVFP” as a Virtual directory.
However, when I convert it to an Application and Test Settings, I get “Invalid Application Path”
I’m unable to get it to go.
It’s got to be something in the IIS setup, but I’m stumped.
The current problem is all due to a Re-Install of IIS-7 done to correct an issue with PHP and COM after a
registry cleaner cleaned too much out of my registry.
Before the Re-Install I had been using your ActiveVFP in the same directory, “C:\OBWeb\www\_ActiveVFP” all along with
great success. So the underscore “_” was never a problem.
I think the underscore is only an issue with much older versions of windows.
Mark OBrien
From: [email removed]
Sent: Monday, December 12, 2011 11:17 PM
To: [email removed]
Subject: Re: IIS 7 Installation [activevfp:282712]

From: claudefox

Usually when you get "This error can be caused by a virtual directory not being configured as an application in IIS.", it means you configured as a Virtual Directory and it just needs to be converted to an Application (right click in IIS Manager and 'Convert to Application')


C:\OBWeb\www\_ActiveVFP should work but I would suspect the underscore ("_") if anything. No don't use "Default Web Site" unless you actually named the physical directory that (which you probably shouldn't)..

IOW, I would rename that Physical Directory to not have the underscore and modify the Web Application in IIS manager to read it
or create a new one...


Coordinator
Dec 16, 2011 at 9:44 PM

For my experience the new config.web doesn't work for me.  That's the one with:

<add name="HttpModule_ProcessManifest" type="MazeComputer.AspManifestHelpers.HttpModule_ProcessManifest, AspManifestHelpers" />

so I reverted back to the old config.web ( i think 5.5 doesn't have this) and it works flawlessly.

Coordinator
Dec 17, 2011 at 12:47 PM
Edited Dec 17, 2011 at 1:15 PM
<add name="HttpModule_ProcessManifest" type="MazeComputer.AspManifestHelpers.HttpModule_ProcessManifest, AspManifestHelpers" />

is needed for self-registration IF you're using anything other than ASP.NET 1.1
(which will probably be most people since ASP.NET 1.1 is primarily for GoDaddy)
---------------

So for AVFP5.5 (for ASP.NET 1.1), the HTTPmodules section can be added for optimization like this:
<httpModules>
       <clear/>
<add name="Session" type="System.Web.SessionState.SessionStateModule"/>
</httpModules>

This is within the <system.web> .... </system.web>  section.