Topics: User Forum
Oct 15, 2008 at 10:36 PM
I don't understand exactly how to debug the code in main.prg.

I followed the instructions:
I compiled the application into an exe
cd c:\directory\soft
do c:\directory\soft\prg\webappdebug.prg

A form appeared and http://localhost/soft/default.asp was launched in the browser.

I put a debug/suspend instruction in main.prg at CASE oProp.Action=='hello'
but when I browse to http://localhost/soft/default.asp?action=hello a error page appears

Error Type:
main err#= 1001 line= 59 Feature is not available.1001 Feature is not available. .NULL. .NULL. .NULL. .NULL. .NULL. d:\avfpsoft\soft\soft.exe (0x800A03E9)
/soft/default.asp, line 6

Did I do something wrong?

Oct 17, 2008 at 2:17 AM
Sounds like everything is working right.  Do you have the source open in the vfp editor somewhere??
Oct 17, 2008 at 9:26 PM
Ok, it works now :)
I set Internet Explorer as default browser (it was Firefox before) and know it shows the debug window in VFP.

Dec 27, 2010 at 10:25 AM


if I recompile application to exe, how can I reregistr activevfp.dll to activevfp.exe? When I try to debug, I get error:

Caught .NET exception, source: 00002sdl001m err#= 1001 line= 57 Feature is not available.1001 Feature is not available. .NULL. .NULL. .NULL. .NULL. .NULL. e:\inetpub\wwwroot\activevfp\activevfp.dll message: e:\inetpub\wwwroot\activevfp\activevfp.dll.

Dec 29, 2010 at 5:20 PM

I have tried activevfp.exe /regserver - but it doesn't work.

Dec 30, 2010 at 4:32 AM
Edited Dec 30, 2010 at 4:35 AM

Hmm, with the new version this may not be as straightforward to do.  Main.prg is called from activevfp.dll which can not be compiled without the source code.  So the solution is to download the source code, which is available here as a separate release, and compile the activevfp project to activevfp.exe. 

I guess it would make more sense to include an activevfp.exe in addition to the activevfp.dll in the default release for debugging purposes.  I'll see about updating the current release to include activevfp.exe in addition to activevfp.dll.

Thanks for bringing this to my attention!


BTW, the previous poster (mmarius28) was probably working with the last version of avfp.

Dec 30, 2010 at 4:52 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.