unable to run Active VFP

Topics: User Forum
Apr 25, 2013 at 6:51 PM
== This is probably very simple but I do not know that the problem is ==

Server Error in '/avfp603' Application.
Retrieving the COM class factory for component with CLSID {BEF60CED-FB7C-4835-A927-4EC90F5162CB} failed due to the following error: 80020009 Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)).
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Runtime.InteropServices.COMException: Retrieving the COM class factory for component with CLSID {BEF60CED-FB7C-4835-A927-4EC90F5162CB} failed due to the following error: 80020009 Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)).

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[COMException (0x80020009): Retrieving the COM class factory for component with CLSID {BEF60CED-FB7C-4835-A927-4EC90F5162CB} failed due to the following error: 80020009 Exception occurred. (Exception from HRESULT: 0x80020009 (DISP_E_EXCEPTION)).]
AVFPHandler.ProcessRequest(HttpContext context) +58
AVFPHandler.OnInit(EventArgs e) +36
System.Web.UI.Control.InitRecursive(Control namingContainer) +140
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +480


Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272
Coordinator
Apr 26, 2013 at 5:00 PM
Edited Apr 26, 2013 at 5:04 PM
Is iis in Full-Trust mode?? Make sure you read the Requirements before installing.
Coordinator
May 6, 2013 at 10:36 PM
Did you ever resolve this?

As a note to anyone else that got this same error message, it looks to me that "side by side" COM activation failed for activevfp.dll. Possibly because privileges weren't automatically elevated for the installer for some weird reason. The easy way to make sure when installing is to right-click on the EXE installer and choose "Run as Administrator".

As a last-ditch solution, you could manually register activevfp.dll but that should really NEVER be required (but if it doesn't work and you're in a hurry and need it quick, etc...)
Jun 18, 2013 at 6:37 AM
Last time, I had this kind of similar error. However i forgot how was the message.
Basically I forgot install visual foxpro runtime in a newer computer due to IIS windows 7 is easier to configure IIS.
Jun 18, 2013 at 7:58 PM
Well still no luck.
I have reinstalled avfpdemo 6.03 using the suggestions of running the install in Administrator Mode.
I also manually registered the activevfp.dll

Now I am not getting any errors. The browser just hangs and never errors out. It just states "Waiting for response from localhost"

I am running Vista Home pro. That could be the problem.

Denny
Coordinator
Jun 18, 2013 at 11:06 PM
Are you using IIS Express?? The older dumbed down versions of IIS that ran on the Home versions of Windows don't work very well. Download the latest version of IIS Express and it will work (but not as well as full-blown IIS on the Professional and Server versions of Windows).
Coordinator
Jun 19, 2013 at 9:35 AM
Coordinator
Jun 19, 2013 at 3:26 PM
Well, that version of IIS should NOT be the problem since one of the demos is running on Vista Home Pro without any issues. If you just start all over with a new directory and a new Virtual Directory, it will probably work. And use the INSTALLER if you didn't the first time. Let us know if it works after that.
Jun 19, 2013 at 5:21 PM
The requested page cannot be accessed because the related configuration data for the page is invalid. Detailed Error Information Module IIS Web Core Notification BeginRequest Handler Not yet determined Error Code 0x80070021 Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false". Config File \\?\c:\avfpdemo\web.config Requested URL http://localhost:80/avfpdemo/default.avfp Physical Path c:\avfpdemo\default.avfp Logon Method Not yet determined Logon User Not yet determined Failed Request Tracing Log Directory C:\inetpub\logs\FailedReqLogFiles Config Source 21: </defaultDocument> 22: <handlers> 23: <add verb="*" path="*.avfp" I have uninstalled IIS Server and reinstalled using IIS Express 8.0 At least I am getting a response now. I did make the following changes in the applicationhost.config file <sites> <site name="WebSite1" id="1" serverAutoStart="true"> <application path="/"> <!-- <virtualDirectory path="/" physicalPath="%IIS_SITES_HOME%\WebSite1" /> --> _____________<virtualDirectory path ="/" physicalPath ="C:\avfpdemo" />_____________ </application> <bindings> <binding protocol="http" bindingInformation=":80:localhost" /> </bindings> </site> <siteDefaults> <logFile logFormat="W3C" directory="%IIS_USER_HOME%\Logs" /> <traceFailedRequestsLogging directory="%IIS_USER_HOME%\TraceLogFiles" enabled="true" maxLogFileSizeKB="1024" /> </siteDefaults> <applicationDefaults applicationPool="Clr4IntegratedAppPool" /> <virtualDirectoryDefaults allowSubDirConfig="true" /> I do appreciate your help in this matter. Denny
Jun 26, 2013 at 8:44 PM
Has anyone seen this error ?

Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File \?\c:\avfpdemo\web.config
Jul 22, 2013 at 9:39 AM
Denny,

What happens if you just work with the sample code without your changes? Does it work then?
Sep 19, 2014 at 8:34 AM
I had similar error,

I had exacly just followed explanation in video to instal in localhost without changes anything... but this error dispalyed

what anything wrong..., somebody help me please..

very thanks
Coordinator
Sep 19, 2014 at 7:12 PM
What Windows OS version? Did you install from the zip or Installer? If zip file, then you need to enable 32-bit mode in the app pool. The Installer does these things for you.
Sep 27, 2014 at 5:27 AM
my windows version is windows 7 pro 64,
I install trough installer not zip
I have checked that I had enapble 32 bit mode in app pool

what wrong then...

very thank for your help...
Coordinator
Sep 29, 2014 at 5:34 PM
From the message above:

"As a note to anyone else that got this same error message, it looks to me that "side by side" COM activation failed for activevfp.dll. Possibly because privileges weren't automatically elevated for the installer for some weird reason. The easy way to make sure when installing is to right-click on the EXE installer and choose "Run as Administrator".

As a last-ditch solution, you could manually register activevfp.dll but that should really NEVER be required (but if it doesn't work and you're in a hurry and need it quick, etc...) "
Oct 7, 2014 at 1:58 AM
i'm so sorry, i m realy very novice..

now i got this error message..

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'activevfp_dotnetproxy, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The process cannot access the file because it is being used by another process. (Exception from HRESULT: 0x80070020)

Source Error:


Line 57: <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 58: <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
Line 59: <add assembly="*"/>
Line 60: <add assembly="System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>
Line 61: <add assembly="System.IdentityModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=MSIL"/>

Source File: C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\web.config Line: 59

Assembly Load Trace: The following information can be helpful to determine why the assembly 'activevfp_dotnetproxy' could not be loaded.


WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

i have opened registry trought regedit, below [HKLM\Software\Microsoft\Fusion in the treeview but i can not see EnabLog folder that i can set to 1 as the suggestion...
thank you for your help..
Coordinator
Oct 7, 2014 at 5:57 PM
Edited Oct 7, 2014 at 6:01 PM
Your app pool in IIS should have 32-bit enabled. For some reason I think this is your problem. Check that in IIS.
(the installer does this automatically but for whatever reason may not have completed this part)

It may make sense to just do another install to another folder\virtual directory and make sure you're an Administrator when you do it (rather than fooling with an install that is possibly hosed). If it does the same thing again, maybe try another computer.

But please make sure all requirements are met before installing.