problem with demo on localhost

Topics: User Forum
Feb 4, 2014 at 5:49 PM
I am facing difficulty with running the avfp6 demo on the localhost.

When I try Localhost in the address bar of the browser, I get a "file does not exist error" from activevfp.dll

In the Main.prg Line No 14 & 15 are not working as expected.
so I hard coded the "oProp.Action" to "default" and the "oProp.ext" to "avfp" in line number 16 & 17 respectively.

Now with this fix, the defaut.avfp runs OK in the browser.

Beyond this :-

if I click the "simplelist" link, the browser attempts "http://simplelist.avfp/"
if I click the "sessionlist" link, the browser attempts "http://sessionlist.avfp/"

and I get a Not found error!

If I edit the urls in the address bar to... localhost/simplelist.avfp/, the browser shows the simplelist OK. Same for Sessionlist.

I need your expert advice...


Feb 5, 2014 at 10:01 AM
You installed to the root of the web server and typed in http://localhost ?

What version of IIS (or is it IIS Express) are you using? Did you use the installer or zip file?
Feb 5, 2014 at 3:18 PM
Hi !

thanks for your response.

I am using IIS 7 that came with widows 7. I installed using the installer. version 6.03.

Using the IIS7 Manager, when I click browse...the (Google Chrome) browser opens up showing Localhost in the Address Bar and the error message.....

Caught .NET exception, source: MAIN.PRG 0000865l0098 err#= 1 line= 68 File does not exist.1 File does not exist. .NULL. .NULL. .NULL. .NULL. .NULL. e:\avfp6\activevfp.dll message: e:\avfp6\activevfp.dll

If I directly open the browser and type in localhost...same thing happens

Feb 5, 2014 at 5:55 PM
Hi Sir,

please take a look at this.

Is this fix ..the proper approach?

Feb 6, 2014 at 11:28 AM
I'll look at this later today.

In the meantime, why don't you install ActiveVFP again on the same computer in a different directory using the Installer . AVFP is designed to work right "out of the box" so you don't usually have to worry about these things. It would be interesting to see if the same thing happens.
Feb 6, 2014 at 2:00 PM
Hi Sir,

Thanks for your time.

I have found my mistake. Using the IIS manager I could see that I did not have a site "Default Web Site" under sites. I must have removed that ...

After asking for Virtual Directory Name, The Installer was giving me the error message " could not find SITE object "Default Web Site" ...." . I proceeded beyond this point by creating the Site manually. Hence all the troubles.

I now created a Site "Default Web Site" under Sites and then tried a fresh installation. This worked smoothly.

You are absolutely correct .... AVFP is designed to work right "out of the box" AND AVFP WORKS RIGHT "OUT OF THE BOX".

Sorry for the trouble.

Feb 6, 2014 at 4:37 PM
I'm glad you solved it. This may be instructional for someone else.