Installing ActiveVFP on my Windows 7

Apr 3, 2015 at 2:17 AM
Hello,

Getting back into ActiveVFP and have not run the 6.3 version yet.

Trying to get it up on my Windows 7 PC.

I made all the changes in the Installing instructions, but running into a config error.

Here is the error screen. Thanks.




Detailed Error Information

Module: IIS Web Core

Notification: BeginRequest

Handler: Not yet determined

Error Code: 0x80070021

Config Error
This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

Config File
\?\c:\activevfp\web.config

Requested URL: http://localhost:80/virtual/default.aspx)
Physical Path: c:\activevfp\default.aspx)

Logon Method: Not yet determined
Logon User: Not yet determined


Config Source 21: </defaultDocument>
22: <handlers>
23: <add verb="" path=".avfp"
Coordinator
Apr 3, 2015 at 3:28 PM
Found this:

"... had the same problem. Don't remember where I found it on the web, but here is what I did:

Click "Start button"
in the search box, enter "Turn windows features on or off"
in the features window, Click: "Internet Information Services"
Click: "World Wide Web Services"
Click: "Application Development Features"
Check (enable) the features. I checked all but CGI.
btw, I'm using Windows 7."

http://stackoverflow.com/questions/9794985/iis-this-configuration-section-cannot-be-used-at-this-path-configuration-lock
Apr 3, 2015 at 6:35 PM
Edited Apr 3, 2015 at 6:36 PM
Thanks, Claude! It's running like a charm now.

I feel ashamed that I couldn't work on ActiveVFP for over a year, but it looks like lots of improvements were made. Right off the top, everything seems zippier. ActiveVFP really is the ticket to moving VFP forward because so much revolves around making solid HTML websites and applications. It's going to be fun.