Unable to Recompile Activevfp.dll

Topics: Developer Forum, Project Management Forum, User Forum
Oct 30, 2009 at 3:12 PM

Hi there Claude

Got a major hick-up when I try to recompile the Activevfp.dll project.

I am compiling in XP SP3 and get the following error "access to system registry denied'

I tried to google the problem but no solving of the problem.

Do you have any ideas. I even tried starting vfp9.0 in administrator mode without any luck.

I even tried regmon but that confused me even more.

I can also not unregister activevfp.dll using regsvr32 and get another error.

Your help would be appreciated.

Regards

Hendrik Labuschagne

Oct 30, 2009 at 5:29 PM
Edited Oct 30, 2009 at 5:30 PM

Ok, the first thing is do you really need to recompile activevfp.dll.? All application code can (and should) go into main.prg (or other externally called prgs) and/or html files.  The only time you need to recompile activevfp.dll is when you're making changes to some base functionality.

If you really do need to re-complie ActiveVFP.dll then having Administrator rights should do it.  That's the only thing I can think of...

 

Oct 31, 2009 at 9:46 AM

Hi all

This is a very important solution to not being able to compile and even use regsvr32 to register or unregister the activevfp.ll

If the security databses get corrupted the only way to fix it is to restore the security databases by using the link below from microsoft.

Now all the problems with this problem has solved and the website is working fine.

http://support.microsoft.com/kb/313222

I had to recompile the dll as a result of own functionality especially with paramaeters passed to webpages.

This could also be included in the help for later reference by users.

Regards

 

Hendrik Labuschagne

 

 

Oct 31, 2009 at 12:29 PM

Thanks for finding the solution and sharing it!  I had never run across that before..