Server 2003 R2 64bit -share issues

Topics: Developer Forum, User Forum
May 27, 2011 at 6:04 PM

I am hoping someone can provide some insite to the cause of of the following error:

tableauth err#= 1 line= 1545 File 'c:\windows\system32\inetsrv\user.dbf' does not exist.1 File 'c:\windows\system32\inetsrv\user.dbf' does not exist. c:\windows\system32\inetsrv\user.dbf .NULL. .NULL. .NULL. .NULL. c:\inetpub\wwwroot\envoymedicalclinic\maxonline\activevfp.dll error '800a0001'

c:\inetpub\wwwroot\envoymedicalclinic\maxonline\activevfp.dll

/default.asp, line 6


I am using two servers one where the data and share is located is a Server 2003 R2 64bit.  Data is shared in the sysvol directory with a folder that contains the database files to be accessed.  The Share permissions have been changed to "Everyone =Full Rights" trying to troubleshoot this issue.  The IIS server is a Server 2003 32bit system that is only running IIS services and is not a AD or DC, but is part of the local domain.  Within IIS directory security, I have changed the   user account to a domain account.  I have also added this domain account to the local IIS Server as a "power user".

The shared folder is mapped locally under the mapped drive "L:\" and my main.prg has a connection string pointing to "L:\Data"  The mapped drive was mapped using an administrative account, but I have also sucessfully mapped and accessed files using the domain account setup on the IIS Server.

Thinking the issue might be related to the 2003 32bit Server, I setup an XP workstation similarly and also go the same error. 

The initial webpage loads and displays fine until authentication takes place and the page tries to authenticate the logging in user.  Then the above error appears.

I suspect the issue is either tied to the default app pool identity and associated permissions or permissions for another dll that needs to be accessed, but would like some guidance before playing with these settings.

Thanks for the help

FC

Coordinator
May 27, 2011 at 6:27 PM

>>I suspect the issue is either tied to the default app pool identity and associated permissions or permissions for another dll that needs to be accessed, but >>would like some guidance before playing with these settings.

 

This is absolutely the problem.  From the ActiveVFP Documentation: "...you must use Impersonation of an account that has the proper rights to the network data.  The preferred way to do this is to configure IIS Application Pools in IIS 6 and above."  COM+ would be a last resort.


May 28, 2011 at 12:29 AM

Thanks for prompt reply claudefox.

Can you guide me on how I go about setting up impersonation of an account with IIS 6.

Thanks again.

Fausto

Coordinator
May 28, 2011 at 1:35 PM

google is better at guiding people than I am  - give it a try.